teleport not functioning.

Abrondino

New Member
Somehow, I cannot seem to get this teleport to work. Any ideas?

1157

1158

Typing /visitor for people with 100 or less permissions (including myself) does not teleport anyone.

Could there be another event getting in the way, somehow? There are no other events with the trigger of /visitor

I even tried rebuilding the event.

Note: I built it by making a copy of a teleport event that already worked. Would that have anything to do with it?

Thank you!
 

badplayer

Active Member
JFF Member
JFF Supporter
7D2D RAT Supporter
Oh, you need 2 pipes between the command and the Alevel
 

badplayer

Active Member
JFF Member
JFF Supporter
7D2D RAT Supporter
And also, players with 2 word names will have issues. They need to remove the space somehow.
 

badplayer

Active Member
JFF Member
JFF Supporter
7D2D RAT Supporter
You can try it. But the problem would be if you use the /friend {friends name} command, it wouldn't work because of the 2 words.
 

Trekkan

JFF Administrator
Staff member
Yeah, the problem is the missing pipe |. Needs to be || as badplayer said.

As for the player name issue... NEVER use player_name unless it is for display purposes only, or if a command requires a player name. Use the player_steamid instead to assure you have the correct player as well as making sure the system works for players with "odd" names such as spaces or high ASCII characters, etc.

If that was in the example from RAT, I missed it when adding in commands from others as defaults, so thanks for finding that. =)
 

Trekkan

JFF Administrator
Staff member
There isn't, but if you can jump into our Discord, its much easier to help you there. If that isn't possible or you don't want to, please let us know what specific teleport you are attempting (screenshot the event, etc) and what error messages you're seeing (look at the console tab, as well as the RAT Log dropdown on that same tab).
 
Top